#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|,)[789](?=,|$)"
Local $sString = "7,30 IN, Ball Valve,9Trunnion,9, CL 900, BW, Body LTCS, Metal Seat, Gear Operated,37,7, NACE MR 0175/ISO 15156 -with extended pup-piece as pipe schedule. VBFW 91Z08.75 IN,77, Gen manu,7 2500, Flanged,7, Body DSS,8, Trim DSS,75, Ball Valve,9, CL 2500,99, RF,Swing Body DSS,789, Trim DSS, Reduced Bore -770343.254.1,9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")