re = /(?<=^|,)[789](?=,|$)/m
str = '7,30 IN, Ball Valve,9Trunnion,9, CL 900, BW, Body LTCS, Metal Seat, Gear Operated,37,7, NACE MR 0175/ISO 15156 -with extended pup-piece as pipe schedule. VBFW 91Z08.75 IN,77, Gen manu,7 2500, Flanged,7, Body DSS,8, Trim DSS,75, Ball Valve,9, CL 2500,99, RF,Swing Body DSS,789, Trim DSS, Reduced Bore -770343.254.1,9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end