using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|,)[789](?=,|$)";
string input = @"7,30 IN, Ball Valve,9Trunnion,9, CL 900, BW, Body LTCS, Metal Seat, Gear Operated,37,7, NACE MR 0175/ISO 15156 -with extended pup-piece as pipe schedule. VBFW 91Z08.75 IN,77, Gen manu,7 2500, Flanged,7, Body DSS,8, Trim DSS,75, Ball Valve,9, CL 2500,99, RF,Swing Body DSS,789, Trim DSS, Reduced Bore -770343.254.1,9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}