using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\'.+\'|\"".+\""|[^,]+)?(?:\s*,?\s*(\'.+\'|\"".+\""|[^,]+))*";
string input = @"111111111111,'222222222',""33333333333333""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}