re = /\s*(\'.+\'|\".+\"|[^,]+)?(?:\s*,?\s*(\'.+\'|\".+\"|[^,]+))*/
str = '111111111111,\'222222222\',"33333333333333"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end