package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(\'.+\'|\".+\"|[^,]+)?(?:\s*,?\s*(\'.+\'|\".+\"|[^,]+))*`)
var str = `111111111111,'222222222',"33333333333333"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}