#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?)\s(\d+)"
Local $sString = "#Softdrinks" & @CRLF & _
"Cola 2" & @CRLF & _
"Sprote 3" & @CRLF & _
"Fant 4" & @CRLF & _
"Redbull 2" & @CRLF & _
"#Pide-Lahmacun" & @CRLF & _
"Pide Mozarella 12" & @CRLF & _
"Pide Hackfleisch 12" & @CRLF & _
"Pide Feta-Hackfleisch 14" & @CRLF & _
"Pide Spinat 13" & @CRLF & _
"Pide Spinat-Ei 14" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")