import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)\\s(\\d+)";
final String string = "#Softdrinks\n"
+ "Cola 2\n"
+ "Sprote 3\n"
+ "Fant 4\n"
+ "Redbull 2\n"
+ "#Pide-Lahmacun\n"
+ "Pide Mozarella 12\n"
+ "Pide Hackfleisch 12\n"
+ "Pide Feta-Hackfleisch 14\n"
+ "Pide Spinat 13\n"
+ "Pide Spinat-Ei 14\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}