re = /(.*?)\s(\d+)/m
str = '#Softdrinks
Cola 2
Sprote 3
Fant 4
Redbull 2
#Pide-Lahmacun
Pide Mozarella 12
Pide Hackfleisch 12
Pide Feta-Hackfleisch 14
Pide Spinat 13
Pide Spinat-Ei 14
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end