#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)((?<= )[\w.]+$)(?=.*(?<= )(\1)$)"
Local $sString = "src/test/resources" & @CRLF & _
"|-- WPCDPS" & @CRLF & _
"| `-- RiskIndicatorsEvaluationRuleTest.feature" & @CRLF & _
"|-- Accelerated.feature" & @CRLF & _
"|-- AcceptedAFS.feature" & @CRLF & _
"|-- AgeValidationRemoval.feature" & @CRLF & _
"|-- Anxiety.feature" & @CRLF & _
"|-- CheckDisabledOccupation.feature" & @CRLF & _
"|-- Extended.feature" & @CRLF & _
"|-- Financal.feature" & @CRLF & _
"|-- Fainancial.feature" & @CRLF & _
"|-- FloridaSpecific.feature" & @CRLF & _
"|-- Hypertension.feature" & @CRLF & _
"|-- LifeForceOrPending.feature" & @CRLF & _
"|-- LifestyleInformation.feature" & @CRLF & _
"|-- MinValue.feature" & @CRLF & _
"|-- Occupations" & @CRLF & _
"| |-- OccupationTranslation.feature" & @CRLF & _
"| |-- OccupationsWithPreConditions.feature" & @CRLF & _
"| |-- Accelerated.feature" & @CRLF & _
"| `-- OccupationsWithoutPreConditions.feature" & @CRLF & _
"|-- Florida.feature"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")