re = /((?<= )[\w.]+$)(?=.*(?<= )(\1)$)/m
str = 'src/test/resources
|-- WPCDPS
| `-- RiskIndicatorsEvaluationRuleTest.feature
|-- Accelerated.feature
|-- AcceptedAFS.feature
|-- AgeValidationRemoval.feature
|-- Anxiety.feature
|-- CheckDisabledOccupation.feature
|-- Extended.feature
|-- Financal.feature
|-- Fainancial.feature
|-- FloridaSpecific.feature
|-- Hypertension.feature
|-- LifeForceOrPending.feature
|-- LifestyleInformation.feature
|-- MinValue.feature
|-- Occupations
| |-- OccupationTranslation.feature
| |-- OccupationsWithPreConditions.feature
| |-- Accelerated.feature
| `-- OccupationsWithoutPreConditions.feature
|-- Florida.feature'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end