import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<= )[\\w.]+$)(?=.*(?<= )(\\1)$)";
final String string = "src/test/resources\n"
+ "|-- WPCDPS\n"
+ "| `-- RiskIndicatorsEvaluationRuleTest.feature\n"
+ "|-- Accelerated.feature\n"
+ "|-- AcceptedAFS.feature\n"
+ "|-- AgeValidationRemoval.feature\n"
+ "|-- Anxiety.feature\n"
+ "|-- CheckDisabledOccupation.feature\n"
+ "|-- Extended.feature\n"
+ "|-- Financal.feature\n"
+ "|-- Fainancial.feature\n"
+ "|-- FloridaSpecific.feature\n"
+ "|-- Hypertension.feature\n"
+ "|-- LifeForceOrPending.feature\n"
+ "|-- LifestyleInformation.feature\n"
+ "|-- MinValue.feature\n"
+ "|-- Occupations\n"
+ "| |-- OccupationTranslation.feature\n"
+ "| |-- OccupationsWithPreConditions.feature\n"
+ "| |-- Accelerated.feature\n"
+ "| `-- OccupationsWithoutPreConditions.feature\n"
+ "|-- Florida.feature";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}