package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)update\s+([^;]*?)\s+set\s(?:[^;]*?\s)?where\s+((?:'[^']*'|[^;])*?)\s*;`)
var str = `update codes set character='.' where character = ';' and write_date < now()-5 ;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}