import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "update\\s+([^;]*?)\\s+set\\s(?:[^;]*?\\s)?where\\s+((?:'[^']*'|[^;])*?)\\s*;";
final String string = "update codes set character='.' where character = ';' and write_date < now()-5 ;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}