re = /update\s+([^;]*?)\s+set\s(?:[^;]*?\s)?where\s+((?:'[^']*'|[^;])*?)\s*;/m
str = 'update codes set character=\'.\' where character = \';\' and write_date < now()-5 ;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end