package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d\s*\d?\s*\d?\s*)`)
var str = `1 2 3 4
12345
1 2 3 4
1 2 34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}