const regex = /^(\d\s*\d?\s*\d?\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d\\s*\\d?\\s*\\d?\\s*)', 'gm')
const str = `1 2 3 4
12345
1 2 3 4
1 2 34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}