$re = '/^(\d\s*\d?\s*\d?\s*)/m';
$str = '1 2 3 4
12345
1 2 3 4
1 2 34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);