package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z0-9]*(?:\s*[A-Za-z0-9]+)*)\s*:\s*((?:\d+(?:\.\d*)?|\.\d+)|[A-Za-z0-9]+)?`)
var str = `Ambient Relative Humidity: 31.59
Operator: Bob
Sensor Number: 0001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}