re = /([A-Za-z0-9]*(?:\s*[A-Za-z0-9]+)*)\s*:\s*((?:\d+(?:\.\d*)?|\.\d+)|[A-Za-z0-9]+)?/
str = 'Ambient Relative Humidity: 31.59
Operator: Bob
Sensor Number: 0001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end