import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z0-9]*(?:\\s*[A-Za-z0-9]+)*)\\s*:\\s*((?:\\d+(?:\\.\\d*)?|\\.\\d+)|[A-Za-z0-9]+)?";
final String string = "Ambient Relative Humidity: 31.59\n"
+ "Operator: Bob\n"
+ "Sensor Number: 0001";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}