using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(least|most) significant decimal (\(X+\s?\.\s?X+\))";
string input = @"Beep; Least Significant Decimal (XX . X);
Beep; Least Significant Decimal (XX . X); Numeric;
Beep; Least Significant Decimal (XX . X); System Beep;
Beep; Most Significant Decimal (X . XX);
Beep; Most Significant Decimal (X . XX); Numeric;
Beep; No Decimal;
Beep; No Decimal; Numeric;
Beep; No Decimal; Numeric; System Beep;
Beep; Numeric;
Beep; System Beep;
Leading zeroes; Least Significant Decimal (XX . X); Numeric;
Leading zeroes; No Decimal; Numeric;
Leading zeroes; Numeric;
Least Significant Decimal (XX . X);
Least Significant Decimal (XX . X); Numeric;
Least Significant Decimal (XX . X); Numeric; System Beep;
Least Significant Decimal (XX.X)
Most Significant Decimal (X . XX);
Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;
Most Significant Decimal (X . XX); Numeric;
Most Significant Decimal (X . XX); Numeric; System Beep;
Most Significant Decimal (X.XX)
Most significant decimal (X . XX); Numeric;
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}