// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(least|most) significant decimal (\(X+\s?\.\s?X+\))").unwrap();
let string = "Beep; Least Significant Decimal (XX . X);
Beep; Least Significant Decimal (XX . X); Numeric;
Beep; Least Significant Decimal (XX . X); System Beep;
Beep; Most Significant Decimal (X . XX);
Beep; Most Significant Decimal (X . XX); Numeric;
Beep; No Decimal;
Beep; No Decimal; Numeric;
Beep; No Decimal; Numeric; System Beep;
Beep; Numeric;
Beep; System Beep;
Leading zeroes; Least Significant Decimal (XX . X); Numeric;
Leading zeroes; No Decimal; Numeric;
Leading zeroes; Numeric;
Least Significant Decimal (XX . X);
Least Significant Decimal (XX . X); Numeric;
Least Significant Decimal (XX . X); Numeric; System Beep;
Least Significant Decimal (XX.X)
Most Significant Decimal (X . XX);
Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;
Most Significant Decimal (X . XX); Numeric;
Most Significant Decimal (X . XX); Numeric; System Beep;
Most Significant Decimal (X.XX)
Most significant decimal (X . XX); Numeric;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}