import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(least|most) significant decimal (\\(X+\\s?\\.\\s?X+\\))";
final String string = "Beep; Least Significant Decimal (XX . X);\n"
+ "Beep; Least Significant Decimal (XX . X); Numeric;\n"
+ "Beep; Least Significant Decimal (XX . X); System Beep;\n"
+ "Beep; Most Significant Decimal (X . XX);\n"
+ "Beep; Most Significant Decimal (X . XX); Numeric;\n"
+ "Beep; No Decimal;\n"
+ "Beep; No Decimal; Numeric;\n"
+ "Beep; No Decimal; Numeric; System Beep;\n"
+ "Beep; Numeric;\n"
+ "Beep; System Beep;\n"
+ "Leading zeroes; Least Significant Decimal (XX . X); Numeric;\n"
+ "Leading zeroes; No Decimal; Numeric;\n"
+ "Leading zeroes; Numeric;\n"
+ "Least Significant Decimal (XX . X);\n"
+ "Least Significant Decimal (XX . X); Numeric;\n"
+ "Least Significant Decimal (XX . X); Numeric; System Beep;\n"
+ "Least Significant Decimal (XX.X)\n"
+ "Most Significant Decimal (X . XX);\n"
+ "Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;\n"
+ "Most Significant Decimal (X . XX); Numeric;\n"
+ "Most Significant Decimal (X . XX); Numeric; System Beep;\n"
+ "Most Significant Decimal (X.XX)\n"
+ "Most significant decimal (X . XX); Numeric;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}