using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\#)([^\s]+)""";
string input = @"Some text <a href=""#some-hash1"">some link</a>some content <a href=""#some-hash2"">some link1</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}