package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\#)([^\s]+)"`)
var str = `Some text <a href="#some-hash1">some link</a>some content <a href="#some-hash2">some link1</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}