$re = '/(\#)([^\s]+)"/';
$str = 'Some text <a href="#some-hash1">some link</a>some content <a href="#some-hash2">some link1</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);