#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[^\r\n0-9]*[0-9]){4})(?!(?:\S* ){2})[a-zA-Z0-9 &]{8,}$"
Local $sString = "abcD &EFG" & @CRLF & _
"ABCde f123" & @CRLF & _
"&&12ADSD&&" & @CRLF & _
"" & @CRLF & _
"a bcD &EFG" & @CRLF & _
"AB5Cde f123" & @CRLF & _
"&&12ADSD&&34" & @CRLF & _
"1234567" & @CRLF & _
"nope"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")