re = /^(?!(?:[^\r\n0-9]*[0-9]){4})(?!(?:\S* ){2})[a-zA-Z0-9 &]{8,}$/m
str = 'abcD &EFG
ABCde f123
&&12ADSD&&
a bcD &EFG
AB5Cde f123
&&12ADSD&&34
1234567
nope'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end