const regex = /^(?!(?:[^\r\n0-9]*[0-9]){4})(?!(?:\S* ){2})[a-zA-Z0-9 &]{8,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:[^\\r\\n0-9]*[0-9]){4})(?!(?:\\S* ){2})[a-zA-Z0-9 &]{8,}$', 'gm')
const str = `abcD &EFG
ABCde f123
&&12ADSD&&
a bcD &EFG
AB5Cde f123
&&12ADSD&&34
1234567
nope`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}