re = /\b(\d+(?:\.\d+)?)\/(\d+)\b/m
str = 'This is Logan, the Chow who lived. He solemnly swears he\'s up to lots of good. 9.75/10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end