// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d+(?:\.\d+)?)\/(\d+)\b").unwrap();
let string = "This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}