#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?:instagr(?:\.am|am\.com))\/([\w.-]+)\/$"
Local $sString = "https://www.instagram.com/explore/tags/test/" & @CRLF & _
"https://www.instagram.com/test.profile/" & @CRLF & _
"https://www.instagram.com/explore"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")