import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?(?:instagr(?:\\.am|am\\.com))\\/([\\w.-]+)\\/$";
final String string = "https://www.instagram.com/explore/tags/test/\n"
+ "https://www.instagram.com/test.profile/\n"
+ "https://www.instagram.com/explore";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}