re = /^(?:https?:\/\/)?(?:www\.)?(?:instagr(?:\.am|am\.com))\/([\w.-]+)\/$/m
str = 'https://www.instagram.com/explore/tags/test/
https://www.instagram.com/test.profile/
https://www.instagram.com/explore'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end