import re
regex = re.compile(r"(?:(?<=\s)|\b)@aaa\|sss\b", flags=re.DOTALL)
test_str = "Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5"
subst = "55"
result = regex.sub(subst, test_str)
if result:
print(result)