re = /(?:(?<=\s)|\b)@aaa\|sss\b/
str = 'Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5'
subst = '55'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result