import Foundation
let pattern = #"(?:(?<=\s)|\b)@aaa\|sss\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"55"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)