using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)@aaa\|sss\b";
string substitution = @"55";
string input = @"Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}