$re = '/(?<=\s)@aaa\|sss\b/s';
$str = 'Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5';
$subst = "55";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;