package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{Arabic}a-zA-Z\p{N}]+\h?[\p{N}\p{Arabic}a-zA-Z]*$`)
var str = `john smith
john
john33
خالد محمد
خالد
خال`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}