re = /^[\p{Arabic}a-zA-Z\p{N}]+\h?[\p{N}\p{Arabic}a-zA-Z]*$/m
str = 'john smith
john
john33
خالد محمد
خالد
خال'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end