const regex = /^[\p{Arabic}a-zA-Z\p{N}]+\h?[\p{N}\p{Arabic}a-zA-Z]*$/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{Arabic}a-zA-Z\\p{N}]+\\h?[\\p{N}\\p{Arabic}a-zA-Z]*$', 'gum')
const str = `john smith
john
john33
خالد محمد
خالد
خال`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}