$re = '/(0?[1-9]|1[012])\/(0?[1-9]|[12][0-9]|3[01])\/\d{2} ([0-1]?\d|2[0-3])(?::([0-5]?\d)) (A|P)M/i';
$str = '4/3/19 5:27 AM
12/31/19 11:59 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);