import re
regex = re.compile(r"(0?[1-9]|1[012])\/(0?[1-9]|[12][0-9]|3[01])\/\d{2} ([0-1]?\d|2[0-3])(?::([0-5]?\d)) (A|P)M", flags=re.IGNORECASE)
test_str = ("4/3/19 5:27 AM\n\n"
"12/31/19 11:59 PM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")