using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*""[^""]*""(?:\s+(?:and|or)\s+[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*""[^""]*"")*";
string input = @"userName eq ""bjensen""
(userName eq ""bjensen\"" and familyName co ""O'Malley"")
(userName eq ""bjensen"" and familyName co ""O'Malley"" AND userName eq ""bjensen"" AND familyName co ""O'Malley"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}