re = /(?i)[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*"[^"]*"(?:\s+(?:and|or)\s+[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*"[^"]*")*/m
str = 'userName eq "bjensen"
(userName eq "bjensen\\" and familyName co "O\'Malley")
(userName eq "bjensen" and familyName co "O\'Malley" AND userName eq "bjensen" AND familyName co "O\'Malley")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end