$re = '/(?i)[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*"[^"]*"(?:\s+(?:and|or)\s+[a-z][a-z0-9]*\s+(?:co|eq|gt)\s*"[^"]*")*/m';
$str = 'userName eq "bjensen"
(userName eq "bjensen\\" and familyName co "O\'Malley")
(userName eq "bjensen" and familyName co "O\'Malley" AND userName eq "bjensen" AND familyName co "O\'Malley")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);