package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.]*\.)|\.`)
var str = `59.34343.23`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}