$re = '/^([^.]*\.)|\./m';
$str = '59.34343.23';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;